Home Computer device Motherboard replaced, now my SSD with all my files is not a “valid boot device”

Motherboard replaced, now my SSD with all my files is not a “valid boot device”

0

Processor: Intel Core i7-4770

Graphics card: GeForce GTX 1070
RAM: 8 GB
Windows 10

My PC stopped working a while ago, refusing to even turn on. I replaced the PSU first, but the problem persists. Then I replaced the motherboard (with another of the same model) and now my computer turns on and I can access the BIOS, but Windows does not start. Instead, I’m told to reboot and select a valid boot device. The only boot device/hard drive I connect is my SSD which contains Windows 10 and all my files. I checked, checked and rechecked – all cables are properly connected inside the PC. I went into BIOS and toggled various settings on and off – changed from SATA to IDE and back again, disabled and enabled Secure Boot, plugged the sata cable into all four sata ports on my motherboard and all throw the same error, I even disabled something called ‘CSM’ since some forum posts said it might help, but all it did was cause me to no longer be able to get video output from my GPU . No more having to reset the CMOS battery to get back into BIOS. I also bought new SATA cables, a 3 pack, and those three new cables didn’t make a difference either.

I then created Windows 10 installation media with a USB drive (on another PC) and tried to perform a startup repair on the drive. It failed. Then I tried restoring from three available system restore points, all three restore attempts failed. In an attempt to back up my files, I plugged in an old blank SSD so I could at least do a clean install on it and maybe hook up my current SSD as a secondary drive so I could keep my files. However, with this old blank SSD plugged in, I can’t boot to the USB anymore for some unknown reason. I switched back to my usual SSD, then I can boot to USB again. What in tarnation.

The last thing I managed to do was connect my Windows 10 SSD as a secondary drive in an old PC, and now I can finally at least access my files, so I’m backing up what I can. After that, I guess my next step is to try using the Windows 10 USB to reformat and do a clean reinstall on my Windows 10 SSD, although I have a feeling that will fail as well. Before I do that, I wanted to ask here if anyone has any ideas what I can do to get my computer to boot to my Windows 10 SSD or why it’s not being recognized as a valid boot device.

Thank you.

Edited by raininghost, Yesterday, 9:47 p.m.